New Google Ads Account Not Visible in Account Selector
Problem
A newly connected Google Ads account is not showing up in the account selector drop-down in the Ads module within Siteimprove.
This issue typically occurs right after connecting the account.
Cause
The issue is usually due to missing user permissions. The account may be connected successfully, but if the user hasn’t been granted access to view/manage it, the account will not be visible in the UI.
Solution
- Go to Settings> Manage Accounts> Manage Users inside the Ads module.
- Locate the connected account in the list.
- Click the button "Manage users" next to that account.
- In the user list, ensure the correct user is checked/selected.
- Click Save to apply permissions.
Once done, the account will appear in the user’s drop-down menu.
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